Problems reaching Temp

TxTechSmoker

Member
Messages
6
Grill(s) owned
Stampede
My grill is taking well over an hour and half to reach 400 degrees. Today, with outside temps right around 50, it took over an hour to reach 300 and never got above 330. Grill was set on “full”. Using rec tec pellets.
Is this par for the course? It’s incredibly frustrating...
 

Kim

Well-known member
Messages
113
Grill(s) owned
Stampede
I can tell you a couple of things from my experience and a couple from my phone call with RecTec. First check that the internal temp probe on the cooker isn't touching the wall. It should be directed more toward the inside of the cooker. Once that is done if you still can't get good temps then you can increase your feed rate.

Second, Full doesn't work like you think it should or even like I think that it should. You would think that full would be run wide open and get as hot as possible as quickly as possible. When I used it and the temp stalled at 385° I turned it back to 500° and the temp started going back up again. It still didn't reach 500 but that was before I talked to RecTec.
 

TxTechSmoker

Member
Messages
6
Grill(s) owned
Stampede
I can tell you a couple of things from my experience and a couple from my phone call with RecTec. First check that the internal temp probe on the cooker isn't touching the wall. It should be directed more toward the inside of the cooker. Once that is done if you still can't get good temps then you can increase your feed rate.

Second, Full doesn't work like you think it should or even like I think that it should. You would think that full would be run wide open and get as hot as possible as quickly as possible. When I used it and the temp stalled at 385° I turned it back to 500° and the temp started going back up again. It still didn't reach 500 but that was before I talked to RecTec.
I tried dialing it back to 500 thinking the same thing, but it hasn’t seemed to make a difference.
 
  • Sad
Reactions: Kim

Midwest Economist

Active member
Messages
33
Location
Midwest - United States
Grill(s) owned
Stampede
@TxTechSmoker, I had my Stampede up to 425 the other day to cook a Pizza when it was in the Mid 30 degree range with a North wind....and it took less than half that time to reach 425.

I would try the steps @Kim recommended...and also recommend that you defer to a third party temperature probe that you trust, if you have one. One of the reasons I migrated away from a WSM Cooker after a decade was having to deal with temperature and adjusting manual vents to account for fluctuation, so I can definitely understand your frustration....

Don’t give up yet....if it’s not right, give RECTEC a chance to make it right....they have a great reputation, let them show you.
 
  • Like
Reactions: Kim

flracer43

Member
Messages
19
Grill(s) owned
Stampede
My grill is taking well over an hour and half to reach 400 degrees. Today, with outside temps right around 50, it took over an hour to reach 300 and never got above 330. Grill was set on “full”. Using rec tec pellets.
Is this par for the course? It’s incredibly frustrating...
Should not take that long.
 

Justin

Member
Messages
22
Grill(s) owned
Stampede
Did you call CS? Or have you tried again? Hope your problem has been resolved.
 

Stile 88

Active member
Messages
42
Grill(s) owned
BFG
is the auger turning and also when was the last time you cleaned the burn pot

if the auger isnt turning then the pellets are not getting into the pot same thing with not cleaning the burn pot

did you contact RECTEC and if so what did they say
 

TxTechSmoker

Member
Messages
6
Grill(s) owned
Stampede
Finally called Rec Tec. They asked me to check the internal temp probe and pull it away from the exterior (it wasn’t touching it to begin with), and to trim up the foil lining the drip pan on the front and back (which I’m positive was not an issue to begin with either). They then asked that I do an hour long test burn and send them the temp log from the app. It took about 50 minutes to reach 410* but then suddenly dropped to the 370s by the one hour mark.
They are now sending me a bag of pellets and a new temp probe (for free). They want me to do another burn with the pellets they send me to rule pellets out as the problem. I’ve used nothing but Rec Tec pellets so this seems pointless to me...
When that does nothing they want me to replace the temp probe and do another burn. Hopefully it’s just a faulty probe and I’ll be good to go.
I’ll let y’all know what happens...
 

TxTechSmoker

Member
Messages
6
Grill(s) owned
Stampede
Received the new temp probe. Did another 1 hour burn on “full” after I installed it (which was super easy by the way). Grill reached 400* after 40 minutes, which is an improvement but still not good enough in my opinion. For the next 20 minutes it dropped down to 379 and got back back up to 399 by the hour mark, never getting hotter than 401.
Id say temp probe wasn’t the issue. I’ll see what Rec Tec says next...
 

TxTechSmoker

Member
Messages
6
Grill(s) owned
Stampede
Rec Tec agreed the temp probe wasn’t an issue. They are now sending out a new and bigger auger motor and a new controller. The rep said this would fix my temp issues without question, and that I should be able to get temps up to 550* no problem.
as a show of good faith for my difficulties with this grill they are also sending me a sear kit free of charge.
their customer service has been outstanding to say the least.
 

Nholmes

New member
Messages
2
Grill(s) owned
Stampede, Trailblazer
Had my stampede on full today and it was at 509 degees within an hour, outside temp was bout 40 and i use smoke house pellets apple, cherry,maple blend. I would think with rectec pellets you would get hotter than that.
 
Thread starter Similar threads Forum Replies Date
S Bull RT-700 7
Geo Rec Tec Lounge 4

Latest posts

Top