New Bull owner - can't get wifi connected

Limi Bull Guy

New member
Messages
4
Grill(s) owned
Bull
Received my bull last week and did the initial burn-in and my first cook. Now I'm trying to get the wifi to connect. Confirmed I'm on 2.4ghz. My phone has a great signal and my bull is literally only 6 feet away from my router with only a window between them. I tried troubleshooting using a phone hot-spot. I was able to get the bull to connect if the hotspot phone was a couple feet from the bull.

I've tried 10+ times to connect using my home wifi network and have followed all the troubleshooting suggestions. There is no reason this shouldn't be picking up my home network due to the close proximity to my router. The only way I could get it any closer is to bring it inside my house! I'm assuming it is time for a call to RecTec...

So far I love my bull but the wifi was one of the primary reasons I bought it.
 

Dougfresh

Member
Messages
14
Grill(s) owned
Stampede
I had to go to advanced settings on my orbi router and completely disable the 5ghz band in order to connect.
 

Buckeye smoker

Well-known member
Messages
502
Grill(s) owned
Bull
I had to turn on location on my phone in order to set mine up initially. After that ,I didn't need to.
 

Limi Bull Guy

New member
Messages
4
Grill(s) owned
Bull
I had to go to advanced settings on my orbi router and completely disable the 5ghz band in order to connect.
No luck. Tried turning off the 5G and still couldn't get it to connect. Looks like I need to call RecTec to see what ideas they have.
 

Wslayer

Active member
Messages
40
Location
ND
Grill(s) owned
Stampede
I had to shut my phone down completely after the first try, hooked up immediately when tried second time
 

wheelmods25

New member
Messages
1
Grill(s) owned
Bull
I spoke with customer support over the weekend about this same issue. He stated that there is a bug in the app affecting about 50% of customers and it won't allow a connection even if all of the connection prerequisites are met
 

Limi Bull Guy

New member
Messages
4
Grill(s) owned
Bull
UPDATE - I called Tech Support on Tuesday evening and after about 30-minutes we got it working. Turned off 5ghz band. Went to phone and told phone to forget the 2ghz band. Then reconnected to 2ghz band. Tried connecting again. Had to do this a few times but then it worked on about the third try. I used app last night to remote start my 700, then used app to monitor my 2nd cook on it. I’m a happy guy now!
 

RHEINLEIN

Member
Messages
7
Grill(s) owned
Bull, RT-300
I too spent some time on this. Two things, I have an Xfinity dual band router. I created a second Network so for the 2.3, this is the one I have the Rec Tec App connect to. @nd, I believe my wifi antenna on the bull needed tightened just a whisker (I thought it was tight enough initially. Once you get it, it seems to work lightening fast and without issue.
 

Latest posts

Top